Back
Downtime

EU Payment Gateway API unavailable.

Started 1 Oct at 12:29pm CEST, resolved 1 Oct at 01:07pm CEST.

Resolved

The incident has been resolved.

Posted 1 Oct at 01:07pm CEST.
Created

Our Payment Gateway in the EU region is currently experiencing issues. We have identified the problem and are working on a fix.

Posted 1 Oct at 12:29pm CEST.